[2025-07-09 22:00:24] - Maintenance status was updated to "completed".
Summary: The scheduled maintenance has been completed successfully. Normal operations have resumed.
Posted Jul 09, 2025 - 22:00 UTC
In progress
[2025-07-08 22:00:21] - Maintenance status was updated to "in_progress".
Summary: A scheduled maintenance is currently underway. Further updates will be provided as needed. This may impact IoT SIM connectivity services.
Posted Jul 08, 2025 - 22:00 UTC
Update
[2025-07-08 21:00:26] - Maintenance status was updated to "scheduled".
Summary: A scheduled maintenance is set to commence in 60 minutes, which may impact mobile network services.
Posted Jul 08, 2025 - 21:00 UTC
Update
[2025-07-04 17:06:07] - Maintenance status was updated to "scheduled".
Summary: A provider reports that brief network reattachment may occur as data sessions are being gradually forwarded to redundant clusters. This is a preliminary activity for an upcoming maintenance window.
Posted Jul 04, 2025 - 17:20 UTC
Scheduled
Potential brief network reattachment during maintenance activity affecting data sessions in Europe
Affected countries: DE, FR, IT, ES, GB, NL, BE, AT, PL, SE, DK, FI, NO, CH, PT, IE, GR, CZ, RO, HU