Support tickets delays

Incident Report for Simbase

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 13:09 UTC

Identified

Due to a widespread external service disruption, our help desk is currently unable to process incoming requests. We appreciate your patience as this issue is being resolved. It may take some time before we can review your tickets, as our service provider is working diligently to clear their backlog.
Posted Oct 20, 2025 - 12:40 UTC