Intermittent failures impacting store, SIM operations

Incident Report for Simbase

Resolved

We are resolving this incident as service is stable and Cloudflare reports full recovery on their end is underway.
Posted Nov 18, 2025 - 17:32 UTC

Monitoring

According to our instrumentation, all impacted services have fully recovered; most notably, provisioning and SMS operations of ⚫ BLACK and 🟢 GREEN profile SIM cards are back to normal.

CloudFlare reports a fix has been deployed and they are actively mitigating the remaining issues. We continue to monitor the situation for further developments.
Posted Nov 18, 2025 - 15:53 UTC

Identified

Some of our operations are being impacted by a widespread CloudFlare outage.

Provisioning operations (enabling/disabling SIM cards) and sending SMS messages for ⚫ BLACK and 🟢 GREEN profile SIM cards might sporadically fail at this time.

Diagnostics might sporadically show the message: "We have detected provisioning irregularities with this SIM. Please open a support ticket". You can ignore this message while this incident is ongoing.

The Store and this status page might also be intermittently unavailable during this outage.

You can monitor https://www.cloudflarestatus.com/ for more information.
Posted Nov 18, 2025 - 12:32 UTC
This incident affected: Third party integrations (SIM Provisioning), ⚫ BLACK sim profile (SMS), 🟢 GREEN sim profile (SMS), and API, Dashboard, Store.