[External] - Data service degradation in Belgium

Incident Report for Simbase

Resolved

[2026-03-16 14:50:23] - Incident status was updated.

Summary: The issue has been resolved and services have returned to normal operation.
Posted Mar 16, 2026 - 15:00 UTC

Update

[2026-03-16 13:10:35] - Incident status was updated.

Summary: Severe data service degradation observed in Belgium on a local network. The operator is aware and actively working on resolution. Impact is limited to Belgium only and does not affect international roaming.
Posted Mar 16, 2026 - 13:21 UTC

Investigating

Severe data service degradation detected in Belgium on local network. Issue is limited to Belgium only and does not affect international roaming.

Affected countries: BE
Posted Mar 16, 2026 - 13:21 UTC