Connectivity issues affecting SIM cards starting with 894453*

Incident Report for Simbase

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 08:36 UTC

Monitoring

We have identified irregularities affecting our cellular services and have escalated the issue with our network’s upstream partner. Our team is actively collaborating with their team to resolve this matter as swiftly and effectively as possible.

We appreciate your patience and understanding as we work together to address this situation. If you have any questions or concerns, please feel free to reach out to our support team.
Posted Mar 10, 2025 - 13:18 UTC
This incident affected: Cellular network (Data services (2G/3G/4G/5G), Voice, SMS).