We are pleased to inform you that Verizon has successfully resolved the network outage that was affecting some of our customers. Service on the Verizon network has been fully restored, and you should now experience normal connectivity.
As always, we appreciate your patience and understanding during this time. If you encounter any further issues or have any questions, please don’t hesitate to contact us.
Posted Oct 01, 2024 - 02:19 UTC
Identified
We want to inform you of a current issue affecting Verizon’s network. Verizon has reported widespread outages, and both roaming and direct access to their network may be impacted. Please note that this is an issue on Verizon’s end, and their engineers are actively working to resolve it as quickly as possible.
We understand the importance of staying connected, and we are happy to report that our multi-carrier SIM cards are still functioning properly on AT&T and T-Mobile networks. You can continue to use your Simbase SIM card on these networks without any interruption.
Posted Sep 30, 2024 - 18:20 UTC
This incident affected: Cellular network (Data services (2G/3G/4G/5G), Voice, SMS).