[2025-11-18 15:15:50] - Incident status was updated to "resolved".
Summary: The previously reported incident has been resolved and all services are now fully operational.
Posted Nov 18, 2025 - 15:20 UTC
Monitoring
[2025-11-18 14:44:24] - Incident status was updated to "monitoring".
Summary: Latest tests show successful results and the network block has been lifted. Traffic recovery is being observed. The situation will continue to be monitored to ensure full service restoration, with further updates to follow as recovery progresses.
Posted Nov 18, 2025 - 15:00 UTC
Identified
[2025-11-18 13:36:30] - Incident status was updated to "identified".
Summary: A network routing issue has been confirmed with a UK roaming partner. As a temporary mitigation, access to the affected network has been blocked, allowing devices to connect to other functioning networks in the UK. The issue is being monitored and updates will be provided as available.
Posted Nov 18, 2025 - 14:02 UTC
Update
[2025-11-18 13:00:03] - Incident status was updated to "investigating".
Summary: A service degradation is being investigated affecting connectivity on a UK network. Devices attempting to connect may experience issues. Further updates are expected soon.
Posted Nov 18, 2025 - 13:01 UTC
Investigating
A service degradation is affecting mobile network connectivity in the United Kingdom. Devices attempting to connect to the affected network may experience issues.