[External] - Scheduled Network Maintenance

Scheduled for Nov 18, 15:00 - 18:00 UTC

Update

[2025-11-12 15:50:38] - Maintenance status was updated to "scheduled".

Summary: A provider has announced scheduled maintenance that may cause intermittent connectivity issues during the maintenance window.
Posted Nov 12, 2025 - 16:01 UTC

Scheduled

A supplier is conducting maintenance that may cause intermittent connectivity issues for mobile data services.

Affected countries: XX
Posted Nov 12, 2025 - 16:01 UTC