[External] - Mobile data performance issues in the UK

Incident Report for Simbase

Resolved

[2025-11-18 15:27:49] - Incident status was updated to "resolved".

Summary: The reported incident has been resolved.
Posted Nov 18, 2025 - 15:40 UTC

Update

[2025-11-18 15:27:40] - Incident status was updated to "monitoring".

Summary: A network provider reported that roaming infrastructure was impacted due to link issues with a partner carrier. The problem has been resolved, roaming traffic restored, and business checks are now positive.
Posted Nov 18, 2025 - 15:40 UTC

Monitoring

[2025-11-18 14:37:47] - Incident status was updated to "monitoring".

Summary: The network provider has identified the issue and is working on a fix. Some customers are reporting service recovery.
Posted Nov 18, 2025 - 15:00 UTC

Identified

[2025-11-18 14:30:57] - Incident status was updated to "identified".

Summary: The provider reports seeing recovery in their network. They will continue to monitor the situation.
Posted Nov 18, 2025 - 15:00 UTC

Update

[2025-11-18 14:07:38] - Incident status was updated to "investigating".

Summary: An external internet issue is impacting roaming infrastructure. The provider is currently investigating the problem.
Posted Nov 18, 2025 - 14:20 UTC

Update

[2025-11-18 13:26:37] - Incident status was updated to "investigating".

Summary: A roaming partner in the UK is experiencing performance issues. The issue is under investigation and further updates are expected.
Posted Nov 18, 2025 - 14:00 UTC

Investigating

Performance degradation affecting mobile data services for IoT devices in the United Kingdom. The issue is being investigated by the local network provider.

Affected countries: GB
Posted Nov 18, 2025 - 14:00 UTC