RADIUS service disruption

Incident Report for Simbase

Postmortem

Post-Mortem: RADIUS Service Degradation

Date: 29 December 2025

Incident window: 16:00 – 20:00 UTC

Severity: Partial service disruption

Status: Resolved

Summary

A subset of the RADIUS infrastructure experienced degraded availability due to an internal network routing disruption. This prevented affected RADIUS servers from forwarding accounting and diagnostic logs, which eventually led to service degradation.

Impact

  • Intermittent RADIUS authentication and/or accounting issues for a subset of customers
  • No data loss or configuration changes
  • Impact limited to specific RADIUS instances

Root Cause

The incident was caused by a temporary routing disruption within the private network, introduced during a scheduled update of underlying connectivity components. As a result, outbound traffic from certain RADIUS servers was blocked.

Resolution

The routing issue was identified and corrected, restoring normal outbound connectivity. Affected RADIUS servers were recovered and resumed normal operation.

Preventive Actions

  • Added safeguards around network changes that affect routing and egress
  • Introduced additional validation checks before similar updates
  • Improved monitoring to detect outbound connectivity issues earlier

Lessons Learned

Network routing changes can have indirect effects on dependent services. Additional pre-deployment checks and monitoring are required for changes affecting shared infrastructure components.

Posted Dec 29, 2025 - 19:52 UTC

Resolved

A subset of our RADIUS infrastructure experienced temporary degraded performance due to an internal network routing issue. The issue has been resolved and all services are operating normally. Preventive measures have been implemented.
Posted Dec 29, 2025 - 19:49 UTC
This incident affected: 🔵 BLUE sim profile (Data services (2G/3G/4G/5G)) and 🟡 YELLOW sim profile (Data services (2G/3G/4G/5G)).