Accounting system migration issues

Incident Report for Simbase

Resolved

This incident has been resolved.
Posted May 06, 2026 - 18:54 UTC

Identified

We are extending the maintenance window for the migration of our accounting and billing system to a new provider. We are working through a technical issue and will provide an update shortly. SIM connectivity is not affected.
Posted May 06, 2026 - 18:38 UTC
This incident affected: Dashboard and Store.