Our team has thoroughly addressed the problem, and all systems are now operating normally. We will continue to monitor performance closely to ensure stability.
We appreciate your patience and understanding while we worked to resolve the issue. If you continue to experience any issues, please don't hesitate to reach out to our support team.
Thank you for your cooperation.
Posted Sep 27, 2024 - 17:09 UTC
Investigating
We have identified irregularities affecting our cellular services and have escalated the issue with our network’s upstream partner. Our team is actively collaborating with their team to resolve this matter as swiftly and effectively as possible.
We appreciate your patience and understanding as we work together to address this situation. If you have any questions or concerns, please feel free to reach out to our support team.
Posted Sep 27, 2024 - 16:54 UTC
This incident affected: Cellular network (Data services (2G/3G/4G/5G), Voice, SMS).