[External] - Mobile Network Connectivity Issue in UK

Incident Report for Simbase

Resolved

[2025-11-18 15:13:20] - Incident status was updated to "resolved".

Summary: The reported issue has been confirmed as resolved.
Posted Nov 18, 2025 - 15:20 UTC

Monitoring

[2025-11-18 14:09:32] - Incident status was updated to "monitoring".

Summary: The root cause of the connectivity issue has been identified and a fix has been deployed. Devices are now successfully registering and data/SMS traffic is resuming. The situation will continue to be monitored to ensure network stability.
Posted Nov 18, 2025 - 14:20 UTC

Update

[2025-11-18 13:06:16] - Incident status was updated to "investigating".

Summary: An issue is affecting connectivity on a UK network. Devices attempting to roam on this network may experience registration problems, unstable data, or SMS service issues. Other UK networks are operating normally. Network partners are investigating the problem, and updates will be provided when available.
Posted Nov 18, 2025 - 13:21 UTC

Investigating

A connectivity issue is affecting mobile network services in the UK. Devices may experience difficulties registering on the network and could face unstable data or SMS services. The issue appears to be isolated to one specific carrier, while other UK networks are operating normally.

Affected countries: GB
Posted Nov 18, 2025 - 13:21 UTC