[2026-07-29 09:00:00] - Maintenance status was updated.
Summary: Scheduled maintenance has been completed successfully.
Posted Jul 29, 2026 - 09:01 UTC
In progress
[2026-07-29 07:00:00] - Maintenance status was updated.
Summary: Scheduled maintenance is currently in progress and may impact service availability.
Posted Jul 29, 2026 - 07:01 UTC
Update
[2026-07-22 08:43:00] - Maintenance status was updated.
Summary: Planned maintenance scheduled during a 2-hour window. Service disruption expected to management platform only with no impact on SIM connectivity. Downtime anticipated to be under 1 hour.
Posted Jul 22, 2026 - 09:01 UTC
Scheduled
Planned maintenance on management platform with no impact on SIM connectivity