Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2026 - 09:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 16, 2026 - 18:07 UTC
Scheduled
What's happening: On June 25, 2026, at 9:00 AM UTC, we will migrate all SIM cards with ICCIDs starting with 89103 to our upgraded infrastructure.
Impact: All SIM cards beginning with 89103 may experience a brief interruption to their data connection during the migration, regardless of which breakout is used.
Important for Private Network and Public IP users: If you currently use our Private Network or Public IP services and your SIM cards have not yet been migrated by the start of the maintenance window, these services will no longer be available on your SIM. The SIM will still be able to establish a data session, but will no longer be remotely reachable.
Posted Jun 16, 2026 - 18:06 UTC
This scheduled maintenance affected: SIM Profile: Black (Data Connectivity, SMS Messaging, Voice, Carrier Provisioning), SIM Profile: Green (Data Connectivity, SMS Messaging, Voice, Carrier Provisioning), and SIM Profile: Red (Data Connectivity, SMS Messaging, Voice, Carrier Provisioning).