Potential issue cards starting with 89103

Incident Report for Simbase

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 13:26 UTC

Investigating

We’re currently investigating a potential issue affecting SIM cards starting with 89103.
Our engineering team is actively working to identify the root cause and implement a fix as quickly as possible. We’ll provide updates as soon as we have more information.
Posted Apr 24, 2025 - 06:39 UTC
This incident affected: Cellular network (Data services (2G/3G/4G/5G), Voice, SMS).