[External] - Data Instability
Resolved
[2026-03-31 10:27:53] - Incident status was updated.
Summary: No further issues have been observed with the service.
Posted Mar 31, 2026 - 10:41 UTC
Monitoring
[2026-03-31 09:38:22] - Incident status was updated.
Summary: Service has been restored and monitoring is ongoing.
Posted Mar 31, 2026 - 10:01 UTC
Investigating
[2026-03-31 09:35:19] - Incident status was updated.
Summary: Investigation is currently underway to determine the cause and scope of the incident.
Posted Mar 31, 2026 - 10:01 UTC
Monitoring
Supplier investigating data service instability, service has been restored and is being monitored.
Affected countries: None
Posted Mar 31, 2026 - 09:41 UTC