[2026-09-15 20:00:00] - Maintenance status was updated.
Summary: Scheduled maintenance is currently in progress and may impact service availability.
Posted Sep 15, 2026 - 20:01 UTC
Update
[2026-09-07 10:28:00] - Maintenance status was updated.
Summary: A software upgrade is being performed on network infrastructure which may cause minor service disruptions for up to 15 minutes during the maintenance window.
Posted Sep 07, 2026 - 10:41 UTC
Scheduled
Scheduled IPX software upgrade may cause brief service disruptions up to 15 minutes during maintenance window