Data Connectivity issues with BLACK profile SIM cards

Incident Report for Simbase

Resolved

Service appears to have fully recovered. We will continue to monitor the situation in the following hours.
Posted Sep 08, 2025 - 15:47 UTC

Monitoring

We're noticing improvements in the number of data sessions initiated.

We continue to monitor the situation closely and will provide more updates as soon as they become available.
Posted Sep 08, 2025 - 13:23 UTC

Investigating

An investigation is underway regarding issues affecting Mobile Data services. More information will be provided as it becomes available. Connectivity issues have currently been reported in the US for BLACK profile SIM cards.
Posted Sep 08, 2025 - 12:42 UTC
This incident affected: ⚫ BLACK sim profile (Data services (2G/3G/4G/5G), SMS, Voice).