[2025-09-03 17:30:48] - Incident status was updated to "resolved".
Summary: The reported incident has been fully resolved and all services have been restored to normal operation.
Posted Sep 03, 2025 - 18:00 UTC
Update
[2025-09-03 16:11:55] - Incident status was updated to "investigating".
Summary: Reports of ongoing service issues following an earlier incident affecting a mobile network in the Netherlands. The issue is being investigated in collaboration with the network provider.
Posted Sep 03, 2025 - 16:20 UTC
Investigating
Ongoing service issues affecting a mobile network in the Netherlands