[External] - Mobile Network Degradation in Tanzania

Incident Report for Simbase

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 08:08 UTC

Identified

[2025-10-31 11:20:11] - Incident status was updated to "identified".

Summary: A country-wide network shutdown in Tanzania is ongoing, affecting multiple mobile operators. Devices may experience complete loss of connectivity or degraded service. The situation is being monitored closely, and updates will be provided when available.
Posted Oct 31, 2025 - 11:20 UTC

Update

[2025-10-29 15:47:56] - Incident status was updated to "investigating".

Summary: A service degradation is being investigated affecting two specific networks. Devices attempting to connect to these networks may experience issues. Other networks are operating normally.
Posted Oct 29, 2025 - 16:00 UTC

Investigating

Service degradation reported affecting multiple mobile networks in Tanzania. Devices may experience connectivity issues when attempting to connect to affected networks. Alternative networks are operating normally.

Affected countries: TZ
Posted Oct 29, 2025 - 16:00 UTC